Questions and Answers

0 Like 0 Dislike

Taylor Williams

package install failing

I've been able to install many packages successfully, but when I try to install ndjson it fails.  Any ideas why?  The package says it depends on R >3.2.0, so the R version shouldn't be an issue.

Thanks!

The beginning of the install console log follows.

* installing *source* package ‘ndjson’ ...
** package ‘ndjson’ successfully unpacked and MD5 sums checked
** libs
g++ -std=gnu++11 -I/apps/share64/debian7/R/3.4.0/lib/R/include -DNDEBUG  -I"/apps/share64/debian7/R/3.4.0/lib/R/library/Rcpp/include" -I/usr/local/include   -fpic  -g -O2 -c RcppExports.cpp -o RcppExports.o
g++ -std=gnu++11 -I/apps/share64/debian7/R/3.4.0/lib/R/include -DNDEBUG  -I"/apps/share64/debian7/R/3.4.0/lib/R/library/Rcpp/include" -I/usr/local/include   -fpic  -g -O2 -c gzstream.cpp -o gzstream.o
g++ -std=gnu++11 -I/apps/share64/debian7/R/3.4.0/lib/R/include -DNDEBUG  -I"/apps/share64/debian7/R/3.4.0/lib/R/library/Rcpp/include" -I/usr/local/include   -fpic  -g -O2 -c ndjson.cpp -o ndjson.o
In file included from ndjson.cpp:8:0:
json.h:66:10: error: #error "unsupported GCC version - see https://github.com/nlohmann/json#supported-compilers"

Report abuse

0 Responses

No other responses made.