Support

Support Options

Submit a Support Ticket

 

Questions and Answers

Status: Accepting answers

Anonymous

Error clarification

Hello,

I’m getting the following error when I run a simulation:

can’t read “total vstep” : no such variable while executing

“expr $total_vstep” (file “apps/omenwire/r91/rappture/omenwirewr” line 1)

Could you please explain to me what this error means?

I’m applying a minimum gate voltage of -0.6V and maximum of 0V.

Thank you.

Report abuse

7 Responses

  1. 0 Dislike

    SungGeun Kim

    Hi, I actually got results, but it seems that simulation had some convergence problem, which means that the convergence criterion is hardly met and the results don’t seem to be right. Let me further assist you if you really need to simulate this structure. My e-mail address is kim568@purdue.edu and please tell me why you are doing this simulation and what the analytical(or qualitative) solution looks like.

    Reply Report abuse

    Please login to answer the question.

  2. 0 Dislike

    SungGeun Kim

    Thank you for your question, but I couldn’t duplicate the situation. Could you tell me what other parameter you changed from the default?

    Cancel Report abuse

    Please login to answer the question.

    1. 0 Like 0 Dislike

      Ahmet Ceyhan

      Hello, I was trying to simulate the following structure: Circular nanowire with n++ doped source, intrinsic channel and p++ doped drain. Vds=-0.6V, Vgmin=-0.6V Vgmax=-0.1V. The length of the channel is 20nm and the source and drain extensions are 15nm each. Thank you.

      Reply Report abuse

      Please login to answer the question.

      1. 0 Like 0 Dislike

        SungGeun Kim

        Could you specify the doping density for each region? Thanks

        Report abuse

      2. 0 Like 0 Dislike

        SungGeun Kim

        The error you’ve got is possibly due to simulation failure or no outputs or convergence failure. The total_vstep is read from the output that includes the bias steps that you have applied. If that variable doesn’t exist, that means the simulation doesn’t have any output for your simulation. I am trying to mimicking the simultion with the parameter what you said on this comment.I will come back to you with the output that simulation gives me.

        Report abuse

    2. 0 Like 0 Dislike

      Ahmet Ceyhan

      Sorry I forgot to mention that the channel diamter is 2.5nm and the oxide thickness is 1nm.

      Reply Report abuse

      Please login to answer the question.

  3. 0 Like 0 Dislike

    Benjamin P Haley

    Hi, Thanks for reporting this issue. Let us look at the code and get back to you with an answer.

    Reply Report abuse

    Please login to answer the question.

nanoHUB.org, a resource for nanoscience and nanotechnology, is supported by the National Science Foundation and other funding agencies. Any opinions, findings, and conclusions or recommendations expressed in this material are those of the author(s) and do not necessarily reflect the views of the National Science Foundation.