Support

Support Options

Submit a Support Ticket

 
  • Discoverability Visible
  • Join Policy Invite Only
  • Created 29 Jun 2010

Is there anyone running jobs using nanohub workspace?

  1. Mahesh R Neupane

    Hello! It seems like most of the users here are running their jobs directly to the purdue’s cluster and are not aware of any system specific issues associated while using nanohub workspace. I tried running the nemo5 on nanohub workspace as follows: submit -v coates ./all.mat -i Si_sp3sstar_Klimeck.in nemo-r7031 Si_sp3sstar_Klimeck.in

    I get the error as :

    Permission denied on executable: ./all.mat

    Even when I have all.mat is saved in the same directory. Any guidance in this would be very helpful. Thanks in advance. Mahesh

    Report abuse

  2. James Fonseca

    Hi Mahesh, You need a “-i” before “./all.mat”. See the wiki Jim

    Report abuse

  3. Mahesh R Neupane

    Hi Jim! I tried this: submit -v coates -i ./all.mat -i Si_sp3sstar_Klimeck.in nemo-r7031 Si_sp3sstar_Klimeck.in

    I get the error message as :

    mneupane not member of group ‘submit’ -Attempting to execute: nemo-r7031

    I thought I had permission to submit job. Thanks Mahesh

    Report abuse

  4. James Fonseca

    Hi Mahesh, Everyone in this group should have permission. Please submit a support ticket. https://nanohub.org/feedback/report_problems

    Jim

    Report abuse

  5. Mahesh R Neupane

    Thanks Jim! The issue is resolved. The actual command is as follows: submit -v coates -i ./all.mat nemo-r7031 Si_sp3sstar_Klimeck.in

    It works. Please have it updated in the Wiki page. Mahesh

    Report abuse

  6. James Fonseca

    Hi Mahesh, Glad it is working now. There could be two different issues here. Could you please help me to figure it out?

    If you now try the original command I gave you: submit -v coates -i ./all.mat -i Si_sp3sstar_Klimeck.in nemo-r7031 Si_sp3sstar_Klimeck.in does that run?

    The -i argument basically is saying “these are the input files I need to run” (which in this case should be the materials database and the input file). And then you are submitting the generic command “nemo-r7031 inputfile”.

    So, it seems “-i Si_sp3sstar_Klimeck.in” may be superfluous, but it should still work…If nanoHUB team changed your permissions, that could explain why you weren’t able to submit before.

    Thanks, Jim

    Report abuse

  7. Mahesh R Neupane

    Oh! I was told about the redundancy of using Si_sp3sstar_Klimeck.in after nemo-r7031. It runs without this. However, I tried running the simulation with

    submit -v coates -i ./all.mat -i Si_NW_3nm.in -n 200 -w 6:30:00

    in multiple cores. It does not run beyond the structure setup.

    I have no idea, what is going on with the development team and the nanohub interface. For me, running these input for the system test is quite important before running actual simulation. However, because of these system dependent issues, I am unable to proceed further. I wish someone using nemo5 remotely using nanohub should be able to guide me through this. Thank you for the help. Mahesh

    Report abuse

  8. James Fonseca

    Hi Mahesh, If you are able to run short jobs (e.g., Si_sp3sstar_Klimeck.in)successfully and get the correct output then the nanohub issues seem to be fixed.

    If you are having trouble with the nanowire input file, please attach your input file and output files. Zhengping created that input deck and I will ask him to take a look.

    Thanks, Jim

    Report abuse

  9. Mahesh R Neupane

    Hi Jim! I did manage to run the small simulation. However, I am unable to run large simulation in parallel. I am also in touch with Zhengping and already sent him the output. thanks Mahesh

    Report abuse

  10. James Fonseca

    Great! Please keep me in the loop so I can make changes to wikis,input files, etc. as needed for other users. Thanks, Jim

    Report abuse

  11. Mahesh R Neupane

    Hi Jim! I need one help. If you could, please run the following input deck in parallel using the command:

    submit -v coates -i ./all.mat -i Si_NW_3nm.in -n 200 -w 6:30:00


    I would like to see, if there is any privilege or nanohub issue.

    For me, the simulation never moves from the stage of structure creation. Thanks Mahesh

    Si_NW_3nm.in

    Report abuse

  12. James Fonseca

    What output do you get? when I submit the request submit -v coates -i ./all.mat -i Si_NW_3nm.in -n 200 -w 6:30:00 nemo-r7031 Si_NW_3nm.in

    the stderr file gives me qsub: Job exceeds queue and/or server resource limits

    Report abuse

  13. Tillmann Christoph Kubis

    Hi, checking the resources on coates it seems there are only 64 CPUs reserved for ncn-hub. So please, try to run your command with e.g. … -n 30 first and see what happens. Thanks, Tillmann

    Report abuse

  14. Samiran Ganguly

    a quick question…is there anyway to check on the status of the job (equivalent of qstat of pbs) from the nanoHUB workspace?

    Report abuse

  15. James Fonseca

    Hi Samiran, I’m not aware of any command to do that. When you submit a job, you will automatically get a status update (see below). Is there something else that you need?

    submit -v coates -i ./all.mat -i Si_NW_3nm.in -n 200 -w 5:00 nemo-r7031 Si_NW_3nm.in
    (4335120) Job Submitted at coates Thu Apr 26 15:23:16 2012
    (4335120) Simulation Queued at coates Thu Apr 26 15:23:26 2012
    (4335120) Simulation Running at coates Thu Apr 26 15:23:41 2012
    (4335120) Simulation Running at coates Thu Apr 26 15:29:16 2012
    (4335120) Simulation Done at coates Thu Apr 26 15:29:56 2012
    

    Also, with workspace, you should be able to close your browser window after submitting.

    Thanks, Jim

    Report abuse

  16. Mahesh R Neupane

    Hi Tillman! I did try 20 nodes but no luck. Is it 64 CPUs per user or for all the users? I have no idea, how to check the job status. Hope, we will get the answer soon. Mahesh

    Report abuse

  17. Tillmann Christoph Kubis

    Well, I am sorry to hear that. The actual command on coates would be “qlist” – that lists the queues you can run and the used and free resource of each queue.

    Report abuse

  18. Mahesh R Neupane

    Hi Tillmann! This command might work for Caotes. However qlist in the nanohub results in a “command not found” error. Mahesh

    Report abuse

  19. James Fonseca

    Hi Mahesh, I’m waiting for our nanohub guy to get back to me about the details of what you can submit, but for the time being, you should basically be able to submit any size (even larger than 64 cores*) job to coates and rossmann as long as the requested walltime is less than or equal to 4 hours.

    *Once I get that reply, I’ll update the wiki with more details about exactly what types of resource requests can be made.

    Please try running something on coates with 200 cores and asking for just 1 minute and see if the job is accepted by the queueing system.

    Thanks, Jim

    Report abuse

  20. Mahesh R Neupane

    Will do that Jim! Did you run the simulation? What kind of output do you get? I am interested to have a look at the log file. I am wondering why it stops at the same point. Mahesh

    Report abuse

  21. James Fonseca

    Hi Mahesh, I’m running the simulation directly on RCAC with 192 cores and walltime of 10 hours (2 hours done so far). I haven’t seen your output where it stops midway. As Gerhard said in his email, the simulation may need to be broken down in smaller pieces… I let you know what I get when it finishes.

    Thanks, Jim

    Report abuse

  22. Mahesh R Neupane

    Hi Jim! Thanks for the clarification. I wonder, if nanohub is running off coates cluster, it should have similar settings as the direct coates environment. In any case, I wish, I had direct access to RCAC. Thanks Mahesh

    Report abuse

  23. Samiran Ganguly

    Hi Jim,

    I just tried “submit -v coates -i ./all.mat -i Si_NW_3nm.in -n 64 -w 10:00 nemo-r7031 Si_NW_3nm.in” to see if I get the thing started…

    I’m not even getting the “Job Submitted” message. By the way, I ssh into nanoHUB rather than run it from the browser, but I don’t think that should be a problem.

    I ran “htop” and I’m attaching the screenshot. I see that submit taking up 100% of one of my cores available to the workspace terminal. I don’t know if the task is getting submitted at all or not.

    I can probably work by submitting things on coates or rossman directly, if that is what is needed. Let me know.

    Report abuse

  24. Mahesh R Neupane

    Hi Samiran! Your job is not running. If it is running in any way, you will see following message (attached). I think, you are lucky to have direct access to coates. If I were you, I would use that directly. Hope it works for you. Mahesh

    Report abuse

  25. James Fonseca

    Hi Mahesh, 1. You can now use revision 7289: nemo-r7289 2. Download the new materials database in the resources section for 7289 3. Regarding the resources, you can request as many nodes as you want, but for right now the walltime is limited to 4 hours. Keep in mind those machines (rossmann/coates) each have a total of 10,000 cores, so anything more than a few hundred may take a while to start running. 4. I’ll try to find out about using qstat via nanohub.

    Thanks, Jim

    Report abuse


nanoHUB.org, a resource for nanoscience and nanotechnology, is supported by the National Science Foundation and other funding agencies. Any opinions, findings, and conclusions or recommendations expressed in this material are those of the author(s) and do not necessarily reflect the views of the National Science Foundation.