
PHYS 10 CURE Lab Exercise 
From the square well model to real atomically thin materials and devices 

Prof. David Strubbe, University of California, Merced, November 2023 
 
Objectives: You will begin by understanding the concept of envelope functions via systems of 
square wells, and the concept of isosurfaces via the hydrogen atom. You will study the 
wavefunctions of a heterojunction of MoS2 and MoSe2 which are atomically thin 2D materials, 
and interpret them in terms of envelope functions. After this preparation, you will calculate the 
structure of a heterojunction of your own pair of 2D materials, and investigate whether the 
wavefunctions are confined (or not) in one of the materials in a way that resembles the square 
well model. This will be your own original research result! 
 
I have noted in some particular places where you should be sure to take screenshots, make 
sketches, or save certain data. In general all the questions and things described for you to look at 
or think about are points that should be addressed in your lab report. My guest lecture on 
Tuesday will be a valuable reference. 
 
 
1. PhET Simulation: quantum wells and envelope functions 
 
We will get warmed up by exploring the concept of envelope functions in a system of square 
wells, like the GaAs/AlGaAs multilayers in a quantum well laser. 
 
In a browser, go to the Quantum Bound States exercise at  
https://phet.colorado.edu/sims/cheerpj/bound-states/latest/bound-
states.html?simulation=bound-states. 
 
We will begin by looking at numerical solutions to the single square well, as you have seen before. 
• Start in the tab “One Well”.  
• Click “Configure Potential” in the upper right and set Width to 0.5 nm, equal to 5×10-10 m. 
• In “Bottom chart” on the right, set “Display:” to “Wave Function”. You will see the 

wavefunction start to oscillate. At the bottom center, click the pause button at a moment 
when the wavefunction is positive and the amplitude looks large. We won’t be interested in 
the time-dependent behavior per se, which may otherwise be a bit distracting. 

• The bottom chart should show the label ψ1(x,t), i.e. the lowest-energy state. The overall view 
should look like this: 



 
 
• Make a sketch and/or save a screenshot of the wavefunction ψ1 (like the one above). 
• In the upper chart, click on the green horizontal lines to select ψ2 and ψ3 [it may be helpful to 

click “Show magnifiying glass (10x)” in the upper right], and again sketch or save the 
wavefunctions, making sure to include the horizontal axis scale. Compare each of these 3 
lowest solutions of the wavefunction to what you have learned in class. 

• Click “Configure Potential”, and set Width to 6.0 nm (the maximum), equal to 6×10-9 m. 
• Again sketch/screenshot ψ1, ψ2, and ψ3. What is similar and what is different between the 

results for 6.0 nm from the original 0.5 nm? 
 
Next, we will investigate a system of many square wells and relate them to the single square well. 
We will set up a system of 10 wells of 0.5 nm width, with a total width close to 6.0 nm, so it has 
a connection to the two single square well systems we looked at. 
• Select the tab “Many Wells (Band Structure)”.  
• Set “Number of Wells” to 10 with the slider. 
• Click “Configure Potential,” and set Height to 20.0 eV (the maximum) via slider or typing. 
• In “Bottom chart” set “Display:” to “Wave Function”. 
• As before, click the pause button at a moment when the amplitude looks large and the 

wavefunction is positive. 



• Sketch ψ1 (you can screenshot too, but we’ll want a sketch, to add more sketches to shortly). 
• Take a look at the next states ψ2 and ψ3 by using the magnifying glass in the Energy diagram 

to select them. They will be all the way at the bottom. Sketch these too. 
• Now consider ψ1 again. Looking at the wavefunction within a single one of the 10 wells, which 

wavefunction of the single 0.5 nm well does this wavefunction resemble most closely? Look 
back at your sketches/screenshots from the One Well. Sketch this corresponding 
wavefunction on your ψ1 sketch. 

• Now looking at the entire wavefunction, which wavefunction of the 6.0 nm well solutions 
does it resemble most closely? This is the envelope function. Again, sketch this wavefunction 
on your ψ1 sketch and label it as the envelope function. The complete wavefunction should 
be equal to the 0.5 nm well solution multiplied by the envelope function. 

• For ψ2 and ψ3, identify their corresponding 0.5 nm well solutions and 6.0 nm well envelope 
functions, and add them to you. Be sure that in making the correspondence to the 0.5 nm 
well solutions you are looking at the right length scale, only at a single 0.5 nm well. If you look 
on a longer length scale, you will be getting this mixed up with the envelope function. 

• You can see from the pattern of the green lines representing energy levels that they form 
several bands that are close in energy. Each band will correspond to one solution of the 0.5 
nm well. Identify the solutions corresponding to the second band around 4 eV and the third 
band around 10 eV, supporting your interpretation with a sketch and/or screenshot. 

 
2. nanoHUB: Wavefunctions and isosurfaces. 
 
Go to https://nanohub.org. Click on “Menu” at the upper right, then Login, and Create Account. 
Use one of the methods offered such as Google or Login through your institution. In any case, 
you will need to enter a bit of info about yourself (for this academic project to keep track a bit 
about who is using it), and confirm your email. When you are logged in, go to the MIT Atomic-
Scale Modeling Toolkit at the URL https://nanohub.org/tools/ucb_compnano. This lab manual 
was prepared for version 5.9.2 of the tool. Click “Launch Tool.” Select from the Applications 
dropdown menu at the upper right: “DFT for Solids, Nanostructures, and Molecules (SIESTA).” 
 
A couple of points to note: 

• nanoHUB will keep your sessions going unless you click “Terminate” or leave them for 
several days, and then can be accessed again from your account at https://nanohub.org.  

• If the nanoHUB window shrinks down like below or doesn’t respond, you can reload the 
page.  

 



• If the simulation doesn’t seem to run, or you don’t have a Simulate button, click “Clear” 
or “Clear All” at the bottom. 

• If you hover the mouse over an option in the graphical user interface (GUI), generally 
some text will appear to give you more information. 

 
• Begin by setting the following parameters: 
Basis: double zeta with polarization (DZP) (decent) 
[controls the number of atomic-like orbitals used to describe the wavefunctions] 
Plot wavefunctions in XCrySDen? yes 
Wavefunction band index minimum: 1 
Wavefunction band index maximum: 5 
Type of System: Molecule 
Coordinates (Cartesian): [by typing, delete what is there and enter this:] 
1 
 
H 0.0 0.0 0.0 
 
This input will give us a simulation of a single atom of hydrogen (H). 
• Before running, resize the window by dragging the bottom right corner, where it says a size 

such as “780 x 600” – make it bigger, or else one of the windows later won’t show some 
buttons. A size like 881 x 732, for example, worked. 

• Now click Simulate.  
 
• An XCrySDen tab will open. XCrySDen is a common program for visualizing structures and 

other outputs from density-functional theory (DFT) calculations.1  You will see a big blue 
sphere, representing the H atom.  

• Go to the File menu at the top, and click Close. 
• Go to File again, and click Open Structure -> Open XSF (XCrySDen Structure File). 
• A new tab “File Browser” will pop open listing the files available to view. RHO.xsf is the total 

electron density, and WFN1,2,3,4,5 are the wavefunctions. Click on WFN1.xsf to start with. 
 

 
1 You can resort if necessary to the documentation at http://www.xcrysden.org/Documentation.html for help. 
 



 
 
• Go to the Tool menu at the top, then select Data Grid.  Another tab will pop open saying 

“DataGrid” and “Wavefunction 1” within it. Click Ok at the bottom right.  
 

 
 
• A tab labeled “iso” will open up. Look for the “Minimum grid value” and “Maximum grid value” 

in the lower left. Choose whichever one is nonzero, and then enter as “Isovalue” about 10% 
of that value (including a negative sign if it is negative). Click Submit in the lower right. (If you 
don’t see the button, resize the window to make it bigger, close this tab, and reopen it by 
repeating the previous step.) 

 



 
 
• Click on the XCrySDen tab to return to it. You will see just some yellow shades. Go to “Zoom–” 

in the upper right and click many times to zoom out, till you see a yellow sphere. You can also 
try scrolling via the mouse or touchscreen. 

• This sphere is an isosurface, showing where the wavefunction is equal to the isovalue. We 
are looking at the lowest-energy 1s orbital of H. Save a screenshot. Click and drag to look from 
other angles to see that it is a sphere. 

• Return to the “iso” tab and double the isovalue you used. Click Submit. How does the 
isosurfaces compare to the previous one in size and/or shape? Save a screenshot (don’t zoom 
in or out, to keep the same scale). 

• Double the isovalue again, compare to the previous ones, and save a screenshot. 
 
• Click File->Close, and File->Open Structure -> Open XSF (XCrySDen Structure File). This time, 

choose WFN3.xsf which will be a 2p orbital. 
• Repeat the sequence of Tools->Data Grid, where it will say “Wavefunction 3”. Click Ok. 
• This time you will find that the Minimum grid value and Maximum grid value are both nonzero 

and opposite to each other. Set the isovalue to 10% of the Maximum grid value, and select 
“Render +/- isovalue.” Click Submit. 



 
• Zoom out again until you see the orbital, as a pair of blue (positive) and red (negative) lobes, 

with the light blue sphere representing the atom in the middle. The blue surface is where the 
wavefunction is equal to the positive isovalue and the red surface is where it has minus that 
value. Save a screenshot. 

• Again, double the isovalue, see how the isosurfaces changes in size and/or shape, and save a 
screenshot. 

• Double once more. 
 
• Make a sketch of the 1s isosurfaces, centered on the same atom, labeling each with its 

isovalue. Do the same for the 2p isosurfaces. 
 
3a. nanoHUB research calculation:  
Now we will get started on a realistic material system, in particular the novel ones we are trying 
to study. 
 
• Prof. Strubbe will assign you a material. We will work with a pair chosen from 8 options: MoO2, 

MoS2, MoSe2, MoTe2, WO2, WS2, WSe2, WTe2. 
 
• Starting by setting the following parameters (and leaving others as they are by default): 
XC Functional: GGA/PBE 



[an approximation within DFT for how electrons interact with each other] 
Basis: double zeta with polarization (DZP) (decent) 
[controls the number of atomic-like orbitals used to describe the wavefunctions] 
Test calculation? yes 
Plot total potential in XCrySDen? yes 
Plot wavefunctions in XCrySDen? no 
Type of System: Sheet/Slab 
k-point sampling in x: 2 
k-point sampling in y: 1 
Sheet/surface slab structure: Molybdenum Disulfide (Supercell, 8x1) 
 
Be sure to set “GGA/PBE” – with the default “LDA/CA,” any calculation with W will crash 
immediately because there is a problem with the LDA pseudopotential file for W. 
 
• Next, set up the correct choice of atoms in your structure, in the Coordinates (Cartesian) 

section. The first two lines are the “lattice vectors” in Å which defines the repeat unit of the 
system. Then comes the number of atoms (24), and finally a list of all the atoms, one on each 
line, with the atomic symbol and then the x, y, and z coordinates in Å. The example structure 
is pure MoS2. Replace Mo and S in the first 12 lines with the appropriate atoms of your first 
material. Replace Mo and S in the last 12 lines with the appropriate atoms of your second 
material. This will give a quantum well structure with alternating strips of the two materials, 
each 4 units wide. Check your work carefully. 

• Now click “Simulate”. You will see some text being written in the window as the SIESTA code 
runs, but it isn’t doing much with “test calculation mode.” When it finishes, you will have a 
tab with several panes of text information and plots (largely blank); and an XCrySDen tab 
which shows the atomic structure with only a single unit cell (the repeating unit). 

• In XCrySDen, the balls of different colors are atoms, and each atom type has a different color 
(although they can be quite similar). Bonds are drawn as lines between them – this is just 
based on a somewhat arbitrary distance criterion and does not always correspond to 
chemical or physical intuition about covalent bonding. The box around the atoms indicates 
the repeating unit (the “unit cell”). You can click and drag to look at the structure from 
different angles. Note how it is atomically thin when viewed from the side. You can see the 
coordinate axes by pressing “y” or selecting Display->Coordinate System. You can click “Zoom 
+” or “Zoom –” to zoom in or out, or click the big red arrows in the upper right to move the 
structure in a given direction. You can return to viewing along a given axis by clicking one of 
the buttons in the lower right that has a red arrow in it. 

• Use Display->Atomic Symbols to get atomic labels so you can be sure the elements are as 
intended. Use Modify->Number of Units Drawn [you may have to hold down the mouse 
button on Modify to keep it from selecting another option] to periodically repeat the 
structure: choose 4 in X-dir, 2 in Y-dir, and leave as 1 in Z-dir; then select Ok. The code is 
treating the structure as repeating infinitely in 2D (X and Y), but this setting visualizes the 
repetition. Verify that this structure is indeed what you meant it to be, in terms of your two 
materials. It should look similar to the image below (which I rotated by 90º). If you find there 
is any problem, fix it and repeat. 



 

 
 
• Once you are satisfied you have the right structure, save your input coordinates by going back 

to the SIESTA tab. In the “XYZ Coordinates” pane, download them by clicking the green arrow 
to the right. Click “Input” at the bottom to return to the Input section, and set 

Run type: geometry optimization 
Test calculation? no 
Run in parallel? yes 
• Save a screenshot of your input parameters. 
 
• Click “Simulate.” This will take a little while. If it takes a very long time to get output (e.g. 25 

minutes), or stops with some weird error, you can try doing it with “Run in parallel? No” 
instead, but in that case it will probably take around an hour. In the meantime, open 
https://nanohub.org/tools/ucb_compnano in another browser window or tab, for another 
run. 

 
4. nanoHUB benchmark calculations: MoS2 / MoTe2 system 
 
While your lengthy geometry optimization is running, we will all do the same calculation as a 
benchmark, to get the hang of it. Continue with “DFT for Solids, Nanostructures, and Molecules 
(SIESTA).” 
 
• Set parameters as follows: 
XC Functional: GGA/PBE 
Run type: total energy 
Basis: double zeta with polarization (DZP) (decent) 
Run Jmol viewer? no 
Plot total potential in XCrySDen? yes 
Plot wavefunctions in XCrySDen? yes 
Type of System: Sheet/Slab 
k-point sampling in x: 2 
k-point sampling in y: 1 
Sheet/surface slab structure: Molybdenum Disulfide (Supercell, 8x1) 
Run in parallel? no 
 



• In Coordinates (Cartesian), again replace the first 12 lines with the first material (now, MoS2 
– well, that’s what they are already) and the second 12 lines with the second material (now, 
MoTe2). This will give a quantum well structure with alternating strips of MoS2 and MoTe2, 
each 4 atoms wide. So as not to have to wait too long, we are making the quite significant 
approximation of ignoring the structural changes due to substitution of atoms. 

 
 
• To set the Wavefunction band index fields: we can calculate which is the highest occupied 

state, as follows. We have 8 Mo/W atoms (6 valence electrons each) and 16 S/Se/Te atoms 
(6 valence electrons each) in the structure. (You can try to see why we get these numbers of 
valence electrons based on the periodic table.) We only count valence electrons, i.e. those in 
the outermost shells which are key for bonding, electrical conductivity, and absorption of 
light, because we are able to treat the inner electrons as fixed through a computational 
scheme called a “pseudopotential.” This gives 144 electrons total. There are two electrons 
per state (up and down spins), so there are 72 occupied states. We will aim to see the two 
highest occupied states (71, 72) and two lowest unoccupied states (73, 74). In general, these 



states are much more likely to fit the quantum well model than states that are much higher 
or lower in energy. So, set the parameters as follows: 
Wavefunction band index minimum: 71 
Wavefunction band index maximum: 74 

• Now click “Simulate”. You will see a lot of text being written in the window as the SIESTA code 
runs for a few minutes. Don’t worry about all the details. You will see it take a little while on 
a step about the charge density, which is expected. 
 

• When it finishes, you will have a tab with several panes of text information and plots; and 
two XCrySDen tabs. Confirm from “Key Outputs” that the number of electrons is as expected 
by the reasoning above. 

• Look at the structure in the first (leftmost) XCrySDen tab and confirm that it is the structure 
we were trying to set up, as in the previous section (or else fix it). Save a screenshot of the 
structure in different orientations. 

• In XCrySDen, you can measure the distance between atoms by clicking on “Distance” at the 
bottom left. A new tab called “sel_dist” will open up. Return to the XCrySDen tab where you 
had clicked “Distance,” and click on two atoms to select them; they should be shown in green. 
Return to the “sel_dist” tab (you might need to increase the size of the window overall to see 
it, by clicking and dragging in the lower right corner), and you will see the coordinates of the 
selected atoms. Click “Done” to get the distance between the atoms. 

• Let’s try it out, using a view in the yz plane. Display the coordinate system if needed to help 
you identify that plane. You can also use a button that directly orients the system in that 
plane. 

 
What is the bond distance between an Mo atom and one of its neighboring S atoms? What is 
the thickness of the layer, i.e. the distance between two S atoms on opposite sides? 

 
• Now go to the rightmost XCrySDen tab (RHO.xsf) to visualize the density. This density is not 

just |ψ|2, but the sum of this for each of the 72 occupied wavefunctions. Go to Tools -> Data 
Grid. Where it says “Identifier” you will see the text “Electronic Charge Density (RHO).” Click 
OK. [If you get Error: can’t read “DataGrid(launch_command)”: no s…” then select OK, and in 
the XCrySDen window, use File->Close; File->Open Structure->Open XSF Structure to open 
RHO.xsf.] An isosurface tab will pop up. This is a way of visualizing a scalar function defined 
on a 3D grid: we will see a yellow surface that shows where the function has a specified value. 
It is like a 3D version of “contour lines” such as we can use to visualize a function defined in 



2D, like the elevation of mountains and valleys on a map for hiking. If you find that the 
isosurface tab that pops up lacks the buttons at the bottom, resize as described before. About 
10% of the maximum magnitude (judging by the maximum and minimum values listed) is a 
good isosurface value to put in the red/purple box. The value chosen must be between the 
maximum and minimum or you will get an error, as there is nothing to show in that case. 
Once you have chosen your isovalue, click “Submit” to see the isosurfaces. You can play 
around with different values to get an idea of how the function varies in space. Note that due 
to some limitations of the codes that produce the files to visualize, the isosurfaces and the 
atoms may not cover exactly the same region; if needed for interpretation, remember that 
the atoms periodically repeat in plane. Annoyingly, you will not be able to use 
Modify->Number of Units Drawn in this pane. 

 
• Is the density is concentrated in one material, or the other, or equally distributed over both? 

You will probably find that the view in the yz plane, i.e. where y is horizontal and z is vertical, 
is the most informative, not only for the density but also for the potential and wavefunctions. 

• We don’t need to look at it now, but there is also a related file DRHO.xsf available for viewing, 
which is the difference between the sum of the electron densities of isolated atoms and the 
electron density of the complete system. 

 
• Next, let’s look at the total potential, V(r), which is in the second (rightmost) XCrySDen 

window. You will see the same atomic structure (though presented a bit differently), in the 
unit cell. Set Modify->Number of Units Drawn, In Z-Dir to 2, which will avoid the isosurface 
being split abruptly where it meet the edge of the unit cell. 

• Go to Tools->Data Grid. If you get an error, close the file and load total_potential.XSF in the 
method described above. In Data Grid, it should say “siesta.VT”, and the values should be 
mostly negative, as the potential is attractive so that electrons stay near the atoms rather 
than drifting out into the vacuum. 

• In the isosurfaces tab, select the option to expand to whole structure, and then the “Number 
of Units Drawn” option will apply to the isosurfaces as well as the atoms. 

 
You can zoom in on just one of the copies of the structure and its isosurface which may cross 
into the next unit cell. 



 
• Select a few isosurfaces to visualize the potential, starting with 10% of the minimum value 

(which is much larger in absolute value than the maximum value).  
• Do you see a sign of the potential being different in one material than in the other? This has 

some relation to the chemistry concept of “electronegativity” of atoms. 
 
• Finally, let’s check out the wavefunctions, using either of the XCrySDen tabs to load the files 

with names like WFN*.xsf, as in the H atom example earlier. The number of the wavefunction 
will also be identified in the Data Grid screen. You will find typically that the minimum value 
is minus the maximum value. Again, around 10% of the maximum is a good isovalue. Select 
“Render +/- isovalue.” Now instead of the yellow surface you will get blue and red surfaces, 
which represent the positive and negative values. As recommended above, view in the yz 
plane which will be easiest to interpret. 

• For each of the four wavefunctions, save screenshots that show whether the wavefunction is 
localized in one material or the other, or evenly distributed over both. 

• Make a rough sketch of the “envelope function” of the wavefunction, along the y direction. 
Be sure to include axes in your plot, so that it is clear where your envelope function is positive, 
negative, or zero. Look back at the examples in lecture if needed to refresh your memory, 
recalling that the idea of the envelope function is to divide out the variation of the 
wavefunction on an atomic scale, and look at a larger scale pattern over several atoms. 

• Note whether there is a node in this envelope function, i.e. whether it is like the n=1 or n=2 
or higher solution of the square well. Don’t be distracted by atomic-scale variation or “wiggles” 
of the wavefunction, which are due to the nature of the atomic orbitals (e.g. like the p orbital 
of H) rather than to the envelope function. Also, don’t be distracted by the variation of the 
wavefunction in the z direction, since we are focusing on how the wavefunction varies in the 
y direction. 

 
 
3b. nanoHUB research calculation:  
 
• Check back on your geometry optimization. When it is finished, the simulation should have 

found the coordinates for the atoms to minimize the energy of the system, i.e. the equilibrium 
structure. 

• Download the “Key Outputs” pane by clicking on the green arrow to the right, and the “SIESTA 
input file (FDF)” – you won’t necessarily understand the stuff in here, but it can be useful in 
diagnosing later if something went wrong. 



• Download the final coordinates from the “XYZ Coordinates” pane. Include these in your lab 
report. 

• You can then add to this file the first three lines shown in the coordinates for the 
“Molybdenum Disulfide (Supercell, 8x1)” example structure in the nanoHUB tool, which are 
defining the lattice vectors (dimensions of the unit cell), so that it looks like the example 
except for the details of the exact coordinates. Upload this file as coordinates for a new 
calculation, by selecting “Upload” under “Sheet/slab structure”. 

  
 
• Then use “Run type” set to “total energy,” and turn back on both options for the XCrySDen 

visualization, including setting Wavefunction band index minimum to 71 and Wavefunction 
band index maximum to 74. 

• Proceed as above in part 3, to study the density, potential, and wavefunctions of your 
heterostructure, and analyze to what extent the results resemble the quantum well model. 

• Examine the structure in XCrySDen, and look for the effect we discussed in class in which 
bonds and layer thickness are lengthened as per the atomic radii, RW > RMo and RTe > RSe > RS. 

 
 
5. Exploration of other aspects of your results. 
• Finally, explore something else you find interesting within the outputs (the XCrySDen views 

or the text panes of output) of this simulation. You don’t need to carry out further simulations 
which would be more time-consuming. There is quite a lot of information there of which we 
have only scratched the surface, and the idea is for you to poke around a bit and see what 
else you find. 

• Make note for your lab report of what you looked at and how, using screenshots to show it, 
and see if you can figure out the physical meaning or origin. It’s ok if you can’t figure out the 
meaning, as some things don’t have a simple explanation, require more advanced condensed 
matter physics knowledge to understand, or are artefacts of the numerical scheme used in 
these calculations. Feel free to discuss what you find with Prof. Strubbe, Kevin, Elsa, or Rafael. 

 
Special Halloween-themed activity, if you have time: 

• Look for where the word “ghost” appears in the “SIESTA output” file. 


