Knowledge Base

Help! I'm getting a Java error!

Users may experience a Java error on Mac OS X if they are using Java version 1.3 and below. Please ensure your Java install is up to date.

NOTE! For gecko browsers (Mozilla, Firefox, Camino), the following may be the source of the error:

Mozilla will only use JRE 1.3.1, even if a later JRE is installed [Bug 197813]. To use a newer JRE, you will need to install the Java Embedding Plugin for Mac OS X. This plugin is beta quality software, and may have bugs and cause problems. Read the Readme before installing it.

Java for Windows, Mac OS, Solaris, and Linux can be downloaded here. Instructions for installation may also be found at that site.

If you continue to have trouble despite thinking you have an up-to-date version of Java installed, please see this page for information on debugging.

16 Dislike

Last updated

Comments on this entry

  1. 0 Dislike

    meonan mike


    I don't think we have a gcc3 compiled plugin for the 1.3.1 JRE but there is one for the 1.4.2 JRE. Why can you not use this as it should run 1.3.1 based applets happily?

    If the problem still persists, You can use latest version from Appvn.

    Ben Hardill

    Reply Report abuse

    You must log in to post comments.

Post a comment

Please keep comments relevant to this entry. Comments deemed offensive or inappropriate may be removed.